[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PostgreSql Version


I just want to weigh in here and provide my logic here:

PostgreSQL 7.3 will likely be officially unsupported by the PostgreSQL
core team quite soon.  PostgreSQL 7.4 would follow within a year.
This means that critical bug and security fixes would have to be
backported by third parties if we agreed to support these versions.  I
think the core team of our project would rather stick with officially
supported versions but are willing to provide technical guidance to
those who want to use the software on older versions of PostgreSQL.  I
have no interest in endorsing this application on versions of the
database software which are no longer supported.

Initially I was in favor of supporting 7.4 for one more year.  However
it became clear very quickly that the level of work that was going to
be required to get the database in shape for 7.4 users was going to be
high enough that it was better to drop support for that version one
year earlier than the PostgreSQL core team might do.  Again, I am
still willing to provide technical guidance.  The same holds true for
people wishing to run the software on even older versions of the
software.  I would still expect that we would support PostgreSQL 8.0
for as long as the core team does, but when 8.0 is no longer
supported, the core project would no longer make any effort to
accomodate it and leave that support ot the community (though again,
we would provide guidance).

Also back-porting the software to legacy versions of PostgreSQL might
provide economic opportunities to community members.  But again, I
think there is a difference between offering technical guidance and
supporting it "out of the box."

Best Wishes,
Chris Travers
On 9/25/06, Joshua D. Drake <..hidden..> wrote:
Alejandro Imass wrote:
> Nop. This is using the normal admin.pl interface. Once I select the
> database, multibyte encoding and COA and click continue. I thought it
> had to do with my pg version which was 7.4 (7.4 does not support "ALSO"
> in the rules), but I just installed pg 8.0 and get the same error.

It should be noted that our officially supported version of PostgreSQL
is 8.x+. All due respect but 7.4 is old, very old.

Debian is the exception to the rule here. ALl major Linux distributions
are currently shipping at least 8.x. Including the commercial distros.


Joshua D. Drake


    === The PostgreSQL Company: Command Prompt, Inc. ===
Sales/Support: +1.503.667.4564 || 24x7/Emergency: +1.800.492.2240
    Providing the most comprehensive  PostgreSQL solutions since 1997

Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys -- and earn cash
Ledger-smb-devel mailing list