[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Self-documenting API Proposal

gl.modify = modify_gl(account1, account2, amount, is_debit)

With a large DB app that I wrote we went for "gl_modify" style instead and it was extremely useful in the sense that all the SPs which affect a given object then cluster together (alphabetically). This makes it much easier to see if there is something in the API which does what we need for "inventory", etc. eg has someone already written "inventory_as_at_date" then it's much easier to find

Most people seem to feel that modify_gl is easier to pronouce than gl_modify though...