The foundation for your business
Fork me on GitHub
[ledgersmb-users] Re: Question re 1.7.29 upgrade from 1.6.32
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ledgersmb-users] Re: Question re 1.7.29 upgrade from 1.6.32

I generally use the distribution's libraries unless I need a more recent one, then I install with cpan.

I've installed EHUELS/PGObject-Util-DBAdmin-1.4.0.tar.gz with cpan and have received the same error. I'm planning on reviewing all dependencies and paths latter today.

Thank you,


On Fri, 4 Jun 2021, Erik Huelsmann wrote:

HI Louis,

On Fri, Jun 4, 2021 at 10:08 AM Erik Huelsmann <..hidden..> wrote:
      Hi Louis,

On Fri, Jun 4, 2021 at 7:50 AM Louis B. Moore <..hidden..> wrote:
      I'm running debian buster with postgresql 11. I install from tarball.

The problem you're running into is an outdated version of LedgerSMB::Util::DBAdmin: Buster has version
0.130.1, but 1.7 depends on >=1.3.0.

The reason I couldn't find the dependency is because it's named PGObject::Util::DBAdmin and it has a declared
minimum dependency version of 1.0.1 on LedgerSMB 1.7.x (1.4.0 is advised). Bullseye has 1.4.0. Did you manually
upgrade PGObject::Util::DBAdmin (or any of the other minimum-version specified dependencies)?


http://efficito.com -- Hosted accounting and ERP.
Robust and Flexible. No vendor lock-in.

users mailing list -- ..hidden..
To unsubscribe send an email to ..hidden..