On Fri, Jun 4, 2021 at 10:08 AM Erik Huelsmann <..hidden..
On Fri, Jun 4, 2021 at 7:50 AM Louis B. Moore <..hidden..
I'm running debian buster with postgresql 11. I install from tarball.
The problem you're running into is an outdated version of LedgerSMB::Util::DBAdmin: Buster has version 0.130.1, but 1.7 depends on >=1.3.0.
The reason I couldn't find the dependency is because it's named PGObject::Util::DBAdmin and it has a declared minimum dependency version of 1.0.1 on LedgerSMB 1.7.x (1.4.0 is advised). Bullseye has 1.4.0. Did you manually upgrade PGObject::Util::DBAdmin (or any of the other minimum-version specified dependencies)?