[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Test install of RC-4

On Fri, Sep 30, 2011 at 6:07 PM, David A. Bandel <..hidden..> wrote:
> Folks,
> OK, have just "successfully" installed LedgerSMB-1.3.0-RC4.

Good to know, based on the feedback below.
> Methodology:
> As I'm a glutton for punishment, decided to put up a new VirtualBox
> install w/ Debian Wheezy.  Basic install w/ only Apache2,
> Postgresql-9.1.0, etc.


> Started install.  Had to backtrack and install:
> postgresql-server-dev-9.1 and latex-make (this installs all
> tetex-latex-recommended plus a little more)
> Had to install CPAN Module::Install module
> After that, all seemed to install (all CPAN modules d/l and installed).
> Now, it seems Postgresql has changed things around again.
> Previously, I would install the tablefunc, tsearch2, and pg_trgm
> stored procedures into template1 and have them in any new db I
> created.
> Well, the create-company script can not be used with postgresql-9.1.0
> until you've installed the new extensions.  And apparently, installing
> them in template1 does NOT insure they are installed in new dbs.

That's interesting.
> What worked -- ran the create-company script once (lots of errors --
> missing all the stored procedures); used psql on the testinc database
> and ran: create extension xyz; (xyz being the three stored procedures,
> tablefunc, tsearch2, and pg_tgrm).  Ran the create-company script
> again -- only errors were "blah already exists".   Success -- have all
> stored procedures, tables, etc.

I can think of two actual solutions here.  tsearch2 can be omitted if
you are on Pg 8.3 or higher.  I am thinking about getting rid of the
pg_trgm dependency since it is not currently exposed to the front-end
and would probably be better handled by an add-on anyway.  That leaves

It seems we need some sort of compatibility routine for 9.1, maybe in
Pg database creating the extension outside of a transaction?

However, in trunk I have already gotten rid of *all* contrib
dependencies, but the downside is it only runs on Pg 8.4 or higher. I
am not sure we want to require Pg 8.4 for 1.3.0.

Best Wishes,
Chris Travers