[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Proposal towards more consistent naming


Tod's emails reminded me of something I have wanted to do for a bit.

I think meta_number is a bad name for something associated with
customer or vendor account numbers.  It isn't really human readable.
It arose out of a need to represent these two and occurred early in
the 1.3 development process when we were totally immersed in
SQL-Ledger madness.

I would like to propose we settle on a field name of "control_code"
for any internal or external reference identifier.  As we redo the
financial logic invoice numbers and document reference identifiers
would both be control codes.  This would improve consistency, make
names easier to manage, and improve accessibility of the code.

Any thoughts?

Best Wishes,
Chris Travers

Monitor 25 network devices or servers for free with OpManager!
OpManager is web-based network management software that monitors 
network devices and physical & virtual servers, alerts via email & sms 
for fault. Monitor 25 devices for free with no restriction. Download now
Ledger-smb-devel mailing list